Intermittent Issue
Incident Report for Lexia
Resolved
This incident has been resolved.
Posted Sep 23, 2022 - 12:54 EDT
Investigating
Students and staff may experience interruptions or error screens when trying to access our products. We apologize for the inconvenience and thank you for your patience! We are currently investigating this issue and will update once we know more about the root cause.
Posted Sep 23, 2022 - 11:51 EDT
This incident affected: Core5, PowerUp, myLexia, Clever, and Lexia English.