LETRS and Aspire experiencing extended downtime
Incident Report for Lexia
Resolved
This incident has been resolved.
Posted Aug 28, 2023 - 13:59 EDT
Investigating
We are currently experiencing more downtime to our LETRS and Aspire applications than anticipated due to scheduled data maintenance.

We apologize for the inconvenience. We aim to have the platform available again as soon as possible.
Posted Aug 28, 2023 - 10:12 EDT
This incident affected: LETRS and Lexia Aspire.