PowerUp Student Program Issue

Incident Report for Lexia

Resolved

This incident has been resolved.
Posted 3 months ago. Jan 16, 2025 - 17:07 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 3 months ago. Jan 16, 2025 - 10:36 EST

Investigating

We are currently experiencing an issue that may be preventing students from accessing our PowerUp program. We are working to identify the issue and resolve it as soon as possible.

We apologize for any inconvenience this might cause.
Posted 3 months ago. Jan 16, 2025 - 09:05 EST
This incident affected: PowerUp.