Required Maintenance on Phone System

Incident Report for Lexia

Resolved

The phone system maintenance has been completed. Calls should be processed as expected. Thank you for your patience!
Posted Jun 20, 2025 - 14:43 EDT

Identified

There is required maintenance taking place on the phone system that may cause issues when trying to call.

We recommend going to the Help Center to contact Support if you experience any issues: https://help.lexialearning.com/s/contact
Posted Jun 17, 2025 - 11:44 EDT