Core5 and myLexia Issue

Incident Report for Lexia

Resolved

This incident has been resolved.
Posted 20 days ago. May 22, 2025 - 13:52 EDT

Update

We are continuing to monitor for any further issues.
Posted 21 days ago. May 21, 2025 - 21:44 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 21 days ago. May 21, 2025 - 21:43 EDT

Investigating

We have discovered an issue with our programs, Core5 and myLexia. We are working to identify the issue and resolve as soon as possible.

We apologize for any inconvenience this might cause.
Posted 21 days ago. May 21, 2025 - 19:16 EDT
This incident affected: Core5 and myLexia.