Teacher Program Issue
Incident Report for Lexia
Resolved
This incident has been resolved.
Posted Jul 19, 2023 - 15:53 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 19, 2023 - 08:54 EDT
Investigating
We have discovered an issue with logging into Lexia Academy. We are working to identify and resolve the issue as soon as possible.

We apologize for any inconvenience this might cause.
Posted Jul 17, 2023 - 17:18 EDT
This incident affected: Lexia Academy.