Degraded Performance
Incident Report for Lexia Learning Status
Resolved
This incident has been resolved.
Posted Nov 16, 2021 - 18:04 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 16, 2021 - 12:42 EST
Investigating
Students and staff may experience interruptions or error screens when trying to access our products. We apologize for the inconvenience and thank you for your patience! We are currently investigating this issue and will update once we know more about the root cause.
Posted Nov 16, 2021 - 11:41 EST
This incident affected: Core5, PowerUp, RAPID, myLexia, Clever Single Sign-On, and Lexia English.