Student Dashboard Showing Last Week's Usage/Units

Incident Report for Lexia

Resolved

This incident has been resolved.
Posted 23 days ago. Mar 11, 2025 - 15:29 EDT

Investigating

We are currently investigating an issue with PowerUp students' dashboards showing last week's usage/units gained. We apologize for the inconvenience and thank you for your patience! We will update you once we know more about the root cause.
Posted 24 days ago. Mar 10, 2025 - 11:24 EDT
This incident affected: PowerUp.