Student Program Issue

Incident Report for Lexia

Resolved

This incident has been resolved.
Posted 3 months ago. Jan 16, 2025 - 12:28 EST

Investigating

There is currently an issue with PowerUp displaying students’ usage data on the PowerUp student homepage. All usage is correct and up to date in myLexia. We are working to resolve the issue quickly.

We apologize for any inconvenience this might cause.
Posted 3 months ago. Jan 08, 2025 - 11:02 EST
This incident affected: PowerUp.