LETRS Issue
Incident Report for Lexia
Resolved
This incident has been resolved.
Posted May 01, 2024 - 01:15 EDT
Update
We are continuing to investigate this issue.
Posted May 01, 2024 - 01:14 EDT
Investigating
We have discovered an issue with our programs, LETRS and Lexia Aspire. We are working to identify the issue and resolve it as soon as possible.

We apologize for any inconvenience this might cause.
Posted Apr 30, 2024 - 19:07 EDT
This incident affected: LETRS and Lexia Aspire.